EL Driver 1

From Hackstrich
Jump to: navigation, search

The EL Driver 1 will be an EL wire driver, that can be plugged into the EL Shield (revision 2+) or used standalone as a regular inverter.

  • Generates 80VDC @ ~50-150mA from 4.5-20V in using the LT1737 IC
  • Converts the 80VDC into 160v p-p using an H bridge
    • H bridge is driven from a PIC10F microcontroller
    • Can be set to low frequency, high frequency, or fed a pulse train from an external device

Status

  • 2012-04: Assembled and tested, DC is more stable but still not able to handle much load. Worked on AC converter some, found that the design leaves no way to pull SYNC high, and if you connect it to +V you blow up the PIC. Need to order a new PIC to continue testing.
  • 2012-03-31: Proper FET and transistor ordered/received, will assemble today and re-test.
  • 2012-03-22: Troubleshot more, found some board stuffing issues. Fixed and now it puts out ~80VDC with no load and the output filter disconnected, but output collapses under any load. FET still getting hot and drawing way too much current.
  • 2012-03-21: Assembled DC-DC side, controller chip got very hot. Found two missing caps, added them and it puts out ~0.5VDC with high current draw, FET gets hot.
  • 2012-03-19: PCBs arrived.
  • 2012-03-04: Digikey parts ordered.
  • 2012-02-26: Completed PCB layout and CAM, sent off to Laen for manufacturing. Transformer samples ordered, still need to do the Digikey order.
  • 2012-02-25: Completed design and simulation runs, started schematic entry and BOM creation.
  • 2012-02-21: Decided that the tolerances were just too tight on the existing design, and scrapped it. DC-AC converter can stay, but the DC-DC side needs redesigning. Started a redesign around the LT1737, which is similar to the LT3575 I was using, but uses an external MOSFET, which is a lot more flexible.
  • 2012-02-20: Built the AC converter, troubleshot the software a bunch. Now the built-in high/low frequency modes work fine, the external-sync mode works mostly, but there's a weird short pulse right before it goes into the off-time. Attempted to test, but since the HVDC side isn't generating enough voltage, it won't work yet.
  • 2012-02-18: Lots more troubleshooting, at a reduced current level so nothing gets damaged. Lowered the zener voltage in the snubber which helped a lot, but the snubber still acts too slowly. Will replace the diode in the snubber with a Schottky on Tuesday to avoid the response time associated with p-n diodes, see if that fixes it.
  • 2012-02-04: Lots more troubleshooting. No real progress other than blowing up more controller chips.
  • 2012-01-25: Symbol wasn't wrong, transformer had the mark on the wrong side (my fault, I took it apart and reassembled it wrong). Found that the voltage spike on the primary upon turn-off is blowing up the controller chip's switch.
  • 2012-01-23: Did a lot of troubleshooting. Found the transformer was in backwards, and the symbol must be wrong as once it's in right, the secondary is wired up backwards. Green-wiring the board now to fix that.
  • 2012-01-18: Assembled DC-DC section. Connected to 5V it pulls 250mA and outputs nothing. Troubleshooting needs to be done.
  • 2011-12-04: Completed board layout, finished silkscreen, CAM files output and sent to Laen. Parts still need to be ordered.
  • 2011-12-03: Completed 95% of board, 4 airwires left, then silkscreen/CAM.
  • 2011-12-02: Completed schematic and BOM.
  • 2011-12-01: Completed most of the schematic and BOM, LEDs still remaining to be done.
  • 2011-11-30: Design of flyback converter based around LT3575 finalized. Started the schematic entry.
  • 2011-11-29 and prior: LTspice simulations to finalize design.

Revision 1 Issues

  • Fixed in rev. 2 - Secondary of transformer is backwards
  • Fixed in rev. 2 - HFREQ/SYNC and HV_SHDN pins are reversed

Revision 2 Issues

  • 3.3v regulator for logic has max. 6V input, but module is supposed to take up to 20 (replace with MCP1804)
  • ID pins are connected to raw input, should be off the regulated supply or to GND
  • Fixed on rev. 1 BOM - Q2/Q3 missing from BOM
  • Fixed on rev. 1 BOM - C8/C9 listed as C6/C7 on BOM
  • Fixed on rev. 1 BOM - R19 on BOM as 1.8k, s/b 20k (also on as 20k)
  • Fixed on rev. 1 BOM - R20/21 stuffed wrong, double check BOM is correct (wasn't)
  • D1 backwards on schematic
  • /SHDN pin on LDO not connected